Command ------- Explaination
1. ------ Move the cursor to the top of the paragraph you want to move.
2. ma --- Place a mark named "a" at this location. (Vim will give you no indication that this command has been executed. In other words, the screen will not change.)
3. ------ Move the cursor to the bottom of the paragraph to be moved.
4. d'a -- Delete to mark "a". This puts the deleted text in a cut buffer.
5. ------ Move the cursor to line where the text is to go. The paragraph will be placed after this one.
6. p ---- Paste the text in below the cursor.
Saturday, January 27, 2007
Solaris survival kit
/usr/platform/`uname -i`/sbin/prtdiag -v
Processors
The psrinfo utility displays processor information. When run in verbose mode, it lists the speed of each processor and when the processor was last placed on-line (generally the time the system was started unless it was manually taken off-line).
/usr/sbin/psrinfo -v
Status of processor 1 as of: 12/12/02 09:25:50
Processor has been on-line since 11/17/02 21:10:09.
The sparcv9 processor operates at 400 MHz,
and has a sparcv9 floating point processor.
Status of processor 3 as of: 12/12/02 09:25:50
Processor has been on-line since 11/17/02 21:10:11.
The sparcv9 processor operates at 400 MHz,
and has a sparcv9 floating point processor.
The psradm utility can enable or disable a specific processor.
To disable a processor:
/usr/sbin/psradm -f processor_id
To enable a processor:
/usr/sbin/psradm -n processor_id
The psrinfo utility will display the processor_id when run in either standard or verbose mode.
RAM
The prtconf utility will display the system configuration, including the amount of physical memory.
To display the amount of RAM:
/usr/sbin/prtconf | grep Memory
Memory size: 3072 Megabytes
Disk space
Although there are several ways you could gather this information, the following command lists the amount of kilobytes in use versus total kilobytes available in local file systems stored on physical disks. The command does not include disk space usage from the /proc virtual file system, the floppy disk, or swap space.
df -lk | egrep -v "Filesystem|/proc|/dev/fd|swap" | awk '{ total_kbytes += $2 } { used_kbytes += $3 } END { printf "%d of %d kilobytes in use.\n", used_kbytes, total_kbytes }'
19221758 of 135949755 kilobytes in use.
You may want to convert the output to megabytes or gigabytes and display the statistics as a percentage of utilization.
The above command will list file system usage. If you are interested in listing physical disks (some of which may not be allocated to a file system), use the format command as the root user, or the iostat -En command as a non-privileged user.
Processor and kernel bits
If you are running Solaris 2.6 or earlier, you are running a 32-bit kernel.
Determine bits of processor:
isainfo -bv
Determine bits of Solaris kernel:
isainfo -kv
The psrinfo utility displays processor information. When run in verbose mode, it lists the speed of each processor and when the processor was last placed on-line (generally the time the system was started unless it was manually taken off-line).
/usr/sbin/psrinfo -v
Status of processor 1 as of: 12/12/02 09:25:50
Processor has been on-line since 11/17/02 21:10:09.
The sparcv9 processor operates at 400 MHz,
and has a sparcv9 floating point processor.
Status of processor 3 as of: 12/12/02 09:25:50
Processor has been on-line since 11/17/02 21:10:11.
The sparcv9 processor operates at 400 MHz,
and has a sparcv9 floating point processor.
The psradm utility can enable or disable a specific processor.
To disable a processor:
/usr/sbin/psradm -f processor_id
To enable a processor:
/usr/sbin/psradm -n processor_id
The psrinfo utility will display the processor_id when run in either standard or verbose mode.
The prtconf utility will display the system configuration, including the amount of physical memory.
To display the amount of RAM:
/usr/sbin/prtconf | grep Memory
Memory size: 3072 Megabytes
Although there are several ways you could gather this information, the following command lists the amount of kilobytes in use versus total kilobytes available in local file systems stored on physical disks. The command does not include disk space usage from the /proc virtual file system, the floppy disk, or swap space.
df -lk | egrep -v "Filesystem|/proc|/dev/fd|swap" | awk '{ total_kbytes += $2 } { used_kbytes += $3 } END { printf "%d of %d kilobytes in use.\n", used_kbytes, total_kbytes }'
19221758 of 135949755 kilobytes in use.
You may want to convert the output to megabytes or gigabytes and display the statistics as a percentage of utilization.
The above command will list file system usage. If you are interested in listing physical disks (some of which may not be allocated to a file system), use the format command as the root user, or the iostat -En command as a non-privileged user.
If you are running Solaris 2.6 or earlier, you are running a 32-bit kernel.
Determine bits of processor:
isainfo -bv
Determine bits of Solaris kernel:
isainfo -kv
vlc and ffmpeg on fedora core 5
1) What I tried first was http://www.videolan.org/vlc/download-fedora.html
--> didn't work on fedora core 5
2) Then I did:
rpm -ivh http://rpm.livna.org/livna-release-5.rpm
instead
3) If you are not interested in the vlc player, go to (7)
yum install xvidcore
yum install xvidcore-devel
yum install x264
yum install vlc
when you run vlc, if there is a permission problem, you have to have
System -> Administration -> Security Level and Firewall -> SELinux Tab
set to "Permissive" and not "Enforced"
4) When I played something like schaufel.mpeg, I got:
VLC media player 0.8.4a Janus
vlc: pcm_plug.c:384: snd_pcm_plug_change_channels: Assertion `snd_pcm_format_linear(slv->format)'
failed
5) goto VLC settings -> preferences -> audio -> o/p modules -> advanced
and change the Audio Output Module to Linux OSS Output
Another thing you can do is: vlc schaufel.mpeg --no-audio
6) related topics: Alsa, oss linux audio devices. So now, I am OK to use vlc
7) About ffmpeg, first I need svn version control to get the sources
yum install subversion
8) Compile ffmpeg
svn checkout svn://svn.mplayerhq.hu/ffmpeg/trunk
./configure
./make
Then, you can do something like:
ffmpeg -i videos/schaufel.mpeg -f mp3 toto.mp3
--> didn't work on fedora core 5
2) Then I did:
rpm -ivh http://rpm.livna.org/livna-release-5.rpm
instead
3) If you are not interested in the vlc player, go to (7)
yum install xvidcore
yum install xvidcore-devel
yum install x264
yum install vlc
when you run vlc, if there is a permission problem, you have to have
System -> Administration -> Security Level and Firewall -> SELinux Tab
set to "Permissive" and not "Enforced"
4) When I played something like schaufel.mpeg, I got:
VLC media player 0.8.4a Janus
vlc: pcm_plug.c:384: snd_pcm_plug_change_channels: Assertion `snd_pcm_format_linear(slv->format)'
failed
5) goto VLC settings -> preferences -> audio -> o/p modules -> advanced
and change the Audio Output Module to Linux OSS Output
Another thing you can do is: vlc schaufel.mpeg --no-audio
6) related topics: Alsa, oss linux audio devices. So now, I am OK to use vlc
7) About ffmpeg, first I need svn version control to get the sources
yum install subversion
8) Compile ffmpeg
svn checkout svn://svn.mplayerhq.hu/ffmpeg/trunk
./configure
./make
Then, you can do something like:
ffmpeg -i videos/schaufel.mpeg -f mp3 toto.mp3
Subscribe to:
Posts (Atom)